Pybot Wiki
Advertisement

Problem[]

Whenever I enter generate_family_file.py it automatically opens a new tab in chrome with the source code of the file, anyone know how to fix this? --Nxtstep101 (talk) 15:41, June 13, 2014 (UTC)


Hey, you're not just opening the folder and double clicking on the script you want to use are you? Because that's usually what happens if you do. Be sure that you're navigating to the folder through the Command Prompt.

-- ℂ𝕠𝕣𝕖π•ͺ β„‚π•™π•’π•žπ•“π•–π•£π•€ 17:42, June 13, 2014 (UTC)

Nope, I wasn't, I was using command prompt the whole time. Do I need a more recent version of Python installed on my computer? Right now I think I have version 2.7.0 or something like that. --Nxtstep101 (talk) 21:01, June 13, 2014 (UTC)
You shouldn't, I'm running V2.7.5 and everything is working perfect. Are you making sure you are including the "python" bit before the script name?
-- ℂ𝕠𝕣𝕖π•ͺ β„‚π•™π•’π•žπ•“π•–π•£π•€ 21:11, June 13, 2014 (UTC)
Nope, I wasn't, it worked now. However, it did spit back an error saying it couldn't find the module named "wikipediatools". Any idea why that would come up? Btw, I downloaded Pywikibot from the link on this page. Thanks for all the help so far! --Nxtstep101 (talk) 01:43, June 14, 2014 (UTC)
Hey, try downloading it from this link here, I'm guessing that that previous link didn't download all the dependencies required by Pybot. Now, you'll notice that this download will have a load more scripts, the previous one was a version I did to get rid of any scripts that wouldn't work on Wikia.
Let me know if this helps!
-- ℂ𝕠𝕣𝕖π•ͺ β„‚π•™π•’π•žπ•“π•–π•£π•€ 03:43, June 14, 2014 (UTC)
That worked, thanks! --Nxtstep101 (talk) 02:48, June 18, 2014 (UTC)

Transliterator target not set[]

Hi there, when I try to set pywikibot for the first time with a new family file, I get the error "transliteration target not set". However, the link it gives me to the Wikipedia page (Manual:Pywikipediabot/Windows) only tells me how to solve this problem by adding "transliteration target = none" to user-config.py. The problem is that I can't even get user-config.py to exist in the first place when it's not set up using generate_user_files.py so I have no way of adding this. :P Can anyone help me solve this issue?--Technobliterator 20:22, March 9, 2015 (UTC)

Advertisement